Fix compat with libarchive 2.8.x (killed by 3.10.1-85-ga5e54ec).