2009-07-09 [paul] 3.7.2cvs3
authorPaul Mangan <paul@claws-mail.org>
Thu, 9 Jul 2009 05:56:45 +0000 (05:56 +0000)
committerPaul Mangan <paul@claws-mail.org>
Thu, 9 Jul 2009 05:56:45 +0000 (05:56 +0000)
* configure.ac
use pkgconfig to check for the minimum required
version of GnuTLS

ChangeLog
PATCHSETS
configure.ac

index 5f90b07..27bef55 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2009-07-09 [paul]      3.7.2cvs3
+
+       * configure.ac
+               use pkgconfig to check for the minimum required
+               version of GnuTLS
+
 2009-07-06 [colin]     3.7.2cvs2
 
        * src/prefs_customheader.c
index e706a1e..0ea2080 100644 (file)
--- a/PATCHSETS
+++ b/PATCHSETS
 ( cvs diff -u -r 1.100.2.70 -r 1.100.2.71 AUTHORS;  cvs diff -u -r 1.654.2.3892 -r 1.654.2.3893 configure.ac;  cvs diff -u -r 1.21.2.8 -r 1.21.2.9 po/bg.po;  cvs diff -u -r 1.9.2.15 -r 1.9.2.16 po/cs.po;  cvs diff -u -r 1.58.2.43 -r 1.58.2.44 po/de.po;  cvs diff -u -r 1.60.2.58 -r 1.60.2.59 po/es.po;  cvs diff -u -r 1.1.2.22 -r 1.1.2.23 po/fi.po;  cvs diff -u -r 1.42.2.46 -r 1.42.2.47 po/fr.po;  cvs diff -u -r 1.5.2.13 -r 1.5.2.14 po/hu.po;  cvs diff -u -r 1.1.2.1 -r 1.1.2.2 po/id.po;  cvs diff -u -r 1.34.2.28 -r 1.34.2.29 po/it.po;  cvs diff -u -r 1.16.2.8 -r 1.16.2.9 po/ja.po;  cvs diff -u -r 1.50.2.35 -r 1.50.2.36 po/pt_BR.po;  diff -u /dev/null po/pt_PT.po;  cvs diff -u -r 1.17.2.19 -r 1.17.2.20 po/ru.po;  cvs diff -u -r 1.2.2.27 -r 1.2.2.28 po/sk.po;  cvs diff -u -r 1.1.2.58 -r 1.1.2.59 src/gtk/authors.h;  ) > 3.7.1cvs85.patchset
 ( cvs diff -u -r 1.1.2.20 -r 1.1.2.21 tools/claws.i18n.status.pl;  ) > 3.7.2cvs1.patchset
 ( cvs diff -u -r 1.16.2.37 -r 1.16.2.38 src/prefs_customheader.c;  ) > 3.7.2cvs2.patchset
+( cvs diff -u -r 1.654.2.3896 -r 1.654.2.3897 configure.ac;  ) > 3.7.2cvs3.patchset
index 10ff82e..6498490 100644 (file)
@@ -12,7 +12,7 @@ MINOR_VERSION=7
 MICRO_VERSION=2
 INTERFACE_AGE=0
 BINARY_AGE=0
-EXTRA_VERSION=2
+EXTRA_VERSION=3
 EXTRA_RELEASE=
 EXTRA_GTK2_VERSION=
 
@@ -397,10 +397,10 @@ if test "x$ac_cv_enable_gnutls" != "xno"; then
   OCPPFLAGS="$CPPFLAGS"
   OLDFLAGS="$LDFLAGS"
   GNUTLS_LIBS=""
-  AC_CHECK_HEADER(gnutls/gnutls.h, [
-       AC_CHECK_LIB(gnutls, gnutls_global_deinit,,
-               [ac_cv_enable_gnutls=no])
-  ],[ac_cv_enable_gnutls=no])
+  PKG_CHECK_MODULES(GNUTLS, gnutls >= 2.0.3,
+       [ac_cv_enable_gnutls=yes],
+       [ac_cv_enable_gnutls=no
+        echo "GnuTLS version >= 2.0.3 not found"])
   if test "x$ac_cv_enable_gnutls" = "xyes"; then
    AC_CHECK_HEADER(gpg-error.h,
        [AC_CHECK_LIB(gpg-error, gpg_strerror,,