2006-06-29 [colin] 2.3.1cvs40
authorColin Leroy <colin@colino.net>
Thu, 29 Jun 2006 17:01:39 +0000 (17:01 +0000)
committerColin Leroy <colin@colino.net>
Thu, 29 Jun 2006 17:01:39 +0000 (17:01 +0000)
* src/main.c
Fix transient setting on failing plugins
Patch by Fabien
* src/plugins/pgpcore/sgpgme.c
Only warn for OpenPGP. Most people don't
have CMS available.

ChangeLog
PATCHSETS
configure.ac
src/main.c
src/plugins/pgpcore/sgpgme.c

index 76bf20ce4029b8890db0003f3c21b59ec69efc04..bc500858eb98c8d76003c8fd7773e8d4ad77893e 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2006-06-29 [colin]     2.3.1cvs40
+
+       * src/main.c
+               Fix transient setting on failing plugins
+               Patch by Fabien
+       * src/plugins/pgpcore/sgpgme.c
+               Only warn for OpenPGP. Most people don't
+               have CMS available.
+
 2006-06-29 [colin]     2.3.1cvs39
 
        * src/compose.c
index 6b5feaa0a54918e86ba98b51cb5b28133d137d0f..190f8d4c81214087fe8beaa69f8be63ead6faaff 100644 (file)
--- a/PATCHSETS
+++ b/PATCHSETS
 ( cvs diff -u -r 1.60.2.33 -r 1.60.2.34 src/prefs_actions.c;  ) > 2.3.1cvs37.patchset
 ( cvs diff -u -r 1.274.2.119 -r 1.274.2.120 src/mainwindow.c;  ) > 2.3.1cvs38.patchset
 ( cvs diff -u -r 1.382.2.288 -r 1.382.2.289 src/compose.c;  cvs diff -u -r 1.1.2.20 -r 1.1.2.21 src/plugins/pgpcore/sgpgme.c;  ) > 2.3.1cvs39.patchset
+( cvs diff -u -r 1.115.2.92 -r 1.115.2.93 src/main.c;  cvs diff -u -r 1.1.2.21 -r 1.1.2.22 src/plugins/pgpcore/sgpgme.c;  ) > 2.3.1cvs40.patchset
index 797c058c1c8eab4d5370da289c391afe1bc22046..7e87aa69f266df06674cb39d98a4920770cb72f4 100644 (file)
@@ -11,7 +11,7 @@ MINOR_VERSION=3
 MICRO_VERSION=1
 INTERFACE_AGE=0
 BINARY_AGE=0
-EXTRA_VERSION=39
+EXTRA_VERSION=40
 EXTRA_RELEASE=
 EXTRA_GTK2_VERSION=
 
index 04d8d9ce9791aa057d959e35af09a1d3a5f70a8c..1381e292d94a4a8ddbf33e9bccead720d00bfc1b 100644 (file)
@@ -447,6 +447,7 @@ int main(int argc, char *argv[])
                
        mainwin = main_window_create
                (prefs_common.sep_folder | prefs_common.sep_msg << 1);
+       manage_window_focus_in(mainwin->window, NULL, NULL);
        folderview = mainwin->folderview;
 
        gtk_clist_freeze(GTK_CLIST(mainwin->folderview->ctree));
@@ -535,14 +536,17 @@ int main(int argc, char *argv[])
        }
        
        if (plugin_get_unloaded_list() != NULL) {
+               main_window_cursor_normal(mainwin);
                alertpanel_warning(_("Some plugin(s) failed to load. "
                                     "Check the Plugins configuration "
                                     "for more information."));
+               main_window_cursor_wait(mainwin);
        }
 
        plugin_load_standard_plugins ();
        
        if (!folder_have_mailbox()) {
+               main_window_cursor_normal(mainwin);
                alertpanel_error(_("Sylpheed-Claws has detected a configured "
                                   "mailbox, but could not load it. It is "
                                   "probably provided by an out-of-date "
index 37b5bd0d72c104459190654c1067be8b99cf4702..0d1ed252b8468d5007b4621978d8a8d22992edc4 100644 (file)
@@ -527,7 +527,8 @@ void sgpgme_init()
                                        engineInfo->version ? engineInfo->version:"???",
                                        engineInfo->req_version ? engineInfo->req_version:"???",
                                        engineInfo->file_name ? engineInfo->file_name:"???");
-                               if (gpgme_engine_check_version(engineInfo->protocol) != 
+                               if (engineInfo->protocol == GPGME_PROTOCOL_OpenPGP
+                               &&  gpgme_engine_check_version(engineInfo->protocol) != 
                                        GPG_ERR_NO_ERROR) {
                                        if (engineInfo->file_name && !engineInfo->version) {
                                                alertpanel_error(_("Gpgme protocol '%s' is unusable: "