Require GLib >= 2.36 for Litehtml plugin
authorAndrej Kacian <ticho@claws-mail.org>
Tue, 5 Mar 2019 07:48:11 +0000 (08:48 +0100)
committerAndrej Kacian <ticho@claws-mail.org>
Tue, 5 Mar 2019 07:48:11 +0000 (08:48 +0100)
configure.ac

index 04c6ebb..3ce2dea 100644 (file)
@@ -1133,7 +1133,7 @@ dnl either yes or no, and do the AC_SUBST calls.
 dnl Archive:           libarchive
 dnl Fancy:             Webkit, curl, optionally libsoup-gnome
 dnl Gdata:             libgdata
-dnl Litehtml           a C++ compiler, cairo, fontconfig, gumbo, curl
+dnl Litehtml           a C++ compiler, >=glib-2.36, cairo, fontconfig, gumbo, curl
 dnl Libravatar:                libcurl
 dnl Notification:      optionally libnotify  unity/messaging-menu
 dnl                               libcanberra_gtk hotkey
@@ -1639,6 +1639,8 @@ if test x"$enable_litehtml_viewer_plugin" != xno; then
         if test x"$HAVE_CXX" = xno; then
                 dependencies_missing="C++ compiler $dependencies_missing"
         fi
+        PKG_CHECK_EXISTS([glib-2.0 >= 2.136], [],
+                [dependencies_missing="glib-2.0 >= 2.36 $dependencies_missing"])
         if test x"$HAVE_CAIRO" = xno; then
                 dependencies_missing="cairo $dependencies_missing"
         fi