2005-10-27 [paul] 1.9.15cvs116
authorPaul Mangan <paul@claws-mail.org>
Thu, 27 Oct 2005 07:50:57 +0000 (07:50 +0000)
committerPaul Mangan <paul@claws-mail.org>
Thu, 27 Oct 2005 07:50:57 +0000 (07:50 +0000)
* src/plugins/clamav/clamav_plugin.c
* src/plugins/dillo_viewer/dillo_viewer.c
* src/plugins/mathml_viewer/mathml_viewer.c
* src/plugins/pgpcore/plugin.c
* src/plugins/pgpinline/plugin.c
* src/plugins/pgpmime/plugin.c
* src/plugins/spamassassin/spamassassin.c
* src/plugins/trayicon/trayicon.c
plugin_init() : make error messages more
informative

ChangeLog-gtk2.claws
PATCHSETS
configure.ac
src/plugins/clamav/clamav_plugin.c
src/plugins/dillo_viewer/dillo_viewer.c
src/plugins/mathml_viewer/mathml_viewer.c
src/plugins/pgpcore/plugin.c
src/plugins/pgpinline/plugin.c
src/plugins/pgpmime/plugin.c
src/plugins/spamassassin/spamassassin.c
src/plugins/trayicon/trayicon.c

index 4d2a33e..2e109fc 100644 (file)
@@ -1,3 +1,16 @@
+2005-10-27 [paul]      1.9.15cvs116
+
+       * src/plugins/clamav/clamav_plugin.c
+       * src/plugins/dillo_viewer/dillo_viewer.c
+       * src/plugins/mathml_viewer/mathml_viewer.c
+       * src/plugins/pgpcore/plugin.c
+       * src/plugins/pgpinline/plugin.c
+       * src/plugins/pgpmime/plugin.c
+       * src/plugins/spamassassin/spamassassin.c
+       * src/plugins/trayicon/trayicon.c
+               plugin_init() : make error messages more
+               informative
+
 2005-10-26 [wwp]       1.9.15cvs115
 
        * src/prefs_matcher.c
index 0c4e849..a63fa13 100644 (file)
--- a/PATCHSETS
+++ b/PATCHSETS
 ( cvs diff -u -r 1.60.2.17 -r 1.60.2.18 po/es.po;  ) > 1.9.15cvs113.patchset
 ( cvs diff -u -r 1.49.2.65 -r 1.49.2.66 src/procmime.c;  cvs diff -u -r 1.1.4.10 -r 1.1.4.11 src/gtk/gtksctree.c;  cvs diff -u -r 1.4.2.5 -r 1.4.2.6 src/plugins/spamassassin/libspamc.c;  cvs diff -u -r 1.18.2.9 -r 1.18.2.10 src/plugins/spamassassin/spamassassin.c;  ) > 1.9.15cvs114.patchset
 ( cvs diff -u -r 1.43.2.28 -r 1.43.2.29 src/prefs_matcher.c;  ) > 1.9.15cvs115.patchset
+( cvs diff -u -r 1.13.2.10 -r 1.13.2.11 src/plugins/clamav/clamav_plugin.c;  cvs diff -u -r 1.12.2.6 -r 1.12.2.7 src/plugins/dillo_viewer/dillo_viewer.c;  cvs diff -u -r 1.9.2.5 -r 1.9.2.6 src/plugins/mathml_viewer/mathml_viewer.c;  cvs diff -u -r 1.1.2.2 -r 1.1.2.3 src/plugins/pgpcore/plugin.c;  cvs diff -u -r 1.1.2.3 -r 1.1.2.4 src/plugins/pgpinline/plugin.c;  cvs diff -u -r 1.1.2.12 -r 1.1.2.13 src/plugins/pgpmime/plugin.c;  cvs diff -u -r 1.18.2.10 -r 1.18.2.11 src/plugins/spamassassin/spamassassin.c;  cvs diff -u -r 1.14.2.25 -r 1.14.2.26 src/plugins/trayicon/trayicon.c;  ) > 1.9.15cvs116.patchset
index ed2fc58..4af41f7 100644 (file)
@@ -11,7 +11,7 @@ MINOR_VERSION=9
 MICRO_VERSION=15
 INTERFACE_AGE=0
 BINARY_AGE=0
-EXTRA_VERSION=115
+EXTRA_VERSION=116
 EXTRA_RELEASE=
 EXTRA_GTK2_VERSION=
 
index e75a67f..c4fc5be 100644 (file)
@@ -190,12 +190,12 @@ gint plugin_init(gchar **error)
        gchar *rcpath;
        int no, ret;
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the ClamAV plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(0, 9, 3, 86))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the ClamAV plugin");
                return -1;
        }
 
index 8ff8e6a..105a799 100644 (file)
@@ -165,12 +165,12 @@ static MimeViewerFactory dillo_viewer_factory =
 gint plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the Dillo plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(0, 9, 3, 86))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your vesion of Sylpheed-Claws is too old for the Dillo plugin");
                return -1;
        }
 
index cff3f89..59ab0b0 100644 (file)
@@ -140,12 +140,12 @@ static MimeViewerFactory mathml_viewer_factory =
 gint plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the MathML plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(0, 9, 3, 86))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the MathML plugin");
                return -1;
        }
 
index c9ab20b..900d45f 100644 (file)
 gint plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the PGP/Core plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(1, 9, 12, 40))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the PGP/Core plugin");
                return -1;
        }
 
index bc383a6..aec1f66 100644 (file)
 gint plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the PGP/inline plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(1, 9, 12, 49))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the PGP/inline plugin");
                return -1;
        }
 
index ec61175..88f9aa7 100644 (file)
 gint plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the PGP/MIME plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(1, 9, 12, 40))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the PGP/MIME plugin");
                return -1;
        }
 
index 007523a..f88a911 100644 (file)
@@ -281,12 +281,12 @@ gint plugin_init(gchar **error)
        gchar *rcpath;
 
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the SpamAssassin plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(0, 9, 3, 86))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the SpamAssassin plugin");
                return -1;
        }
 
index e44593e..f8d31e8 100644 (file)
@@ -275,12 +275,12 @@ static void create_trayicon()
 int plugin_init(gchar **error)
 {
        if ((sylpheed_get_version() > VERSION_NUMERIC)) {
-               *error = g_strdup("Your sylpheed version is newer than the version the plugin was built with");
+               *error = g_strdup("Your version of Sylpheed-Claws is newer than the version the Trayicon plugin was built with");
                return -1;
        }
 
        if ((sylpheed_get_version() < MAKE_NUMERIC_VERSION(0, 9, 3, 86))) {
-               *error = g_strdup("Your sylpheed version is too old");
+               *error = g_strdup("Your version of Sylpheed-Claws is too old for the Trayicon plugin");
                return -1;
        }