fix using building with --disable-deprecated
authorPaul <paul@claws-mail.org>
Thu, 2 Mar 2017 14:54:34 +0000 (14:54 +0000)
committerPaul <paul@claws-mail.org>
Thu, 2 Mar 2017 14:54:34 +0000 (14:54 +0000)
commite8c787412d2b6cecc7464431d4fbd9f1eb4614f4
tree968ba7ebec163c0bda8fd22be6751be1f144a6f7
parenta8e50abd1506794e2f314a0277bd6f44b97ab3d9
fix using building with --disable-deprecated

If --disable-deprecated is specified it will set GTK_CFLAGS.
Later the pkgconfig check for GTK_CFLAGS will be skipped because the
variable is already set. As a result essential CLFAGS from gtk+-2.0 will
be missing in global CFLAGS and compilation fails.

Solution is to check for the configure flag after pkgconfig.

Thanks to Olaf Hering <olaf@aepfle.de>
configure.ac