update copyright year
[claws.git] / src / plugins / vcalendar / Makefile.am
index 3e1738fa8f9a60c530e3c1ec7cf0dc742d50a4be..1ad788ba991675c8147c5916ceafe848ad734ae5 100644 (file)
@@ -1,58 +1,16 @@
-# Copyright 1999-2014 the Claws Mail team.
+# Copyright 1999-2022 the Claws Mail team.
 # This file is part of Claws Mail package, and distributed under the
 # terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
-SUBDIRS = libical
-EXTRA_DIST = claws.def plugin.def version.rc
+include $(srcdir)/../win_plugin.mk
 
 IFLAGS = \
+       -I$(top_builddir)/src \
+       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk \
-       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
-
-if OS_WIN32
-
-LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
-     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
-
-%.lo : %.rc
-       $(LTRCCOMPILE) -i $< -o $@
-
-plugin_res = version.lo
-plugin_res_ldflag = -Wl,.libs/version.o
-
-export_symbols = -export-symbols $(srcdir)/plugin.def
-
-plugin_deps = libclaws.a $(plugin_res) plugin.def
-
-libclaws.a: claws.def
-       $(DLLTOOL) --output-lib $@ --def $<
-
-plugin_ldadd = -L. -lclaws
-
-else
-plugin_res =
-plugin_res_ldflag =
-export_symbols =
-plugin_deps =
-plugin_ldadd =
-endif
-
-if PLATFORM_WIN32
-no_undefined = -no-undefined
-else
-no_undefined =
-endif
-
-if CYGWIN
-cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
-else
-cygwin_export_lib = 
-endif
+       -I$(top_srcdir)/src/gtk
 
 plugindir = $(pkglibdir)/plugins
 
@@ -60,39 +18,43 @@ if BUILD_VCALENDAR_PLUGIN
 plugin_LTLIBRARIES = vcalendar.la
 endif
 
-vcalendar_la_SOURCES = \
-       plugin.c \
-       vcalendar.c vcalendar.h \
-       vcal_manager.c vcal_manager.h \
-       vcal_folder.c vcal_folder.h \
-       vcal_meeting_gtk.c vcal_meeting_gtk.h \
-       vcal_prefs.c vcal_prefs.h \
-       vcal_dbus.c vcal_dbus.h \
-       icaltime_as_local.c icaltime_as_local.h \
-       common-views.c common-views.h \
-       day-view.c month-view.c
-
-vcalendarincludedir = $(includedir)/claws-mail/plugins/vcalendar
-vcalendarinclude_HEADERS = \
-       vcal_interface.h
 vcalendar_la_LDFLAGS = \
-       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
-       -avoid-version -module \
-       $(GTK_LIBS)
+       $(plugin_ldflags) \
+       -avoid-version -module -z noexecstack
 
-vcalendar_la_DEPENDENCIES = $(plugin_deps)
+EXTRA_vcalendar_la_DEPENDENCIES = $(plugin_extra_deps)
 
-vcalendar_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
+vcalendar_la_LIBADD = $(plugin_libadd) \
        $(GTK_LIBS) \
        $(CURL_LIBS) \
-        $(top_builddir)/src/plugins/vcalendar/libical/libical/libical.la
+       $(LIBICAL_LIBS)
 
 vcalendar_la_CPPFLAGS = \
        $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(CURL_CFLAGS)
+       $(ENCHANT_CFLAGS) \
+       $(CURL_CFLAGS) \
+       $(LIBICAL_CFLAGS)
 
-clean-local:
-       rm -f libclaws.a
+vcalendar_la_SOURCES = \
+       common-views.c \
+       common-views.h \
+       day-view.c \
+       month-view.c \
+       plugin.c \
+       vcal_dbus.c \
+       vcal_dbus.h \
+       vcal_folder.c \
+       vcal_folder.h \
+       vcal_interface.h \
+       vcal_manager.c \
+       vcal_manager.h \
+       vcal_meeting_gtk.c \
+       vcal_meeting_gtk.h \
+       vcal_prefs.c \
+       vcal_prefs.h \
+       vcalendar.c \
+       vcalendar.h
+
+.PHONY: test