metainfo: add vcalendar plugin
[claws.git] / src / plugins / vcalendar / Makefile.am
index 022efabb6de3933f1f272a75d4b80f8291721ca4..759ef6fdb6528e722c76976361a6c080dabc70cd 100644 (file)
@@ -1,10 +1,25 @@
+# Makefile.am for "src/plugins/vcalendar" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-vcalendar.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+
 SUBDIRS = libical
-EXTRA_DIST = claws.def plugin.def version.rc
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -48,13 +63,6 @@ if BUILD_VCALENDAR_PLUGIN
 plugin_LTLIBRARIES = vcalendar.la
 endif
 
-INCLUDES= \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk \
-       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
-
 vcalendar_la_SOURCES = \
        plugin.c \
        vcalendar.c vcalendar.h \
@@ -83,7 +91,8 @@ vcalendar_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(CURL_LIBS) \
         $(top_builddir)/src/plugins/vcalendar/libical/libical/libical.la
 
-AM_CPPFLAGS = \
+vcalendar_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(CURL_CFLAGS)