Actually encrypt passwords before storing them
[claws.git] / src / plugins / vcalendar / Makefile.am
index 3f32908e541608289bb16ec59534e583b032cc12..3e1738fa8f9a60c530e3c1ec7cf0dc742d50a4be 100644 (file)
@@ -1,10 +1,22 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 SUBDIRS = libical
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -44,14 +56,9 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_VCALENDAR_PLUGIN
 plugin_LTLIBRARIES = vcalendar.la
-
-INCLUDES= \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk \
-       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
+endif
 
 vcalendar_la_SOURCES = \
        plugin.c \
@@ -81,12 +88,11 @@ vcalendar_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(CURL_LIBS) \
         $(top_builddir)/src/plugins/vcalendar/libical/libical/libical.la
 
-AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
+vcalendar_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(CURL_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(CURL_CFLAGS)
 
 clean-local:
        rm -f libclaws.a