add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / vcalendar / Makefile.am
index 022efabb6de3933f1f272a75d4b80f8291721ca4..2c6806ffcb5db672a60090a2b88dce06a0dd68f1 100644 (file)
@@ -1,10 +1,21 @@
+# Makefile.am for "src/plugins/vcalendar" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 SUBDIRS = libical
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -48,13 +59,6 @@ if BUILD_VCALENDAR_PLUGIN
 plugin_LTLIBRARIES = vcalendar.la
 endif
 
-INCLUDES= \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk \
-       -I$(top_srcdir)/src/plugins/vcalendar/libical/libical
-
 vcalendar_la_SOURCES = \
        plugin.c \
        vcalendar.c vcalendar.h \
@@ -83,7 +87,8 @@ vcalendar_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(CURL_LIBS) \
         $(top_builddir)/src/plugins/vcalendar/libical/libical/libical.la
 
-AM_CPPFLAGS = \
+vcalendar_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(CURL_CFLAGS)