2006-03-09 [paul] 2.0.0cvs123
[claws.git] / src / plugins / trayicon / Makefile.am
index 7d6f276ebbfc2175b256dad63a88415ffe97745e..dbf452d88dc5b08c71a9649ef40ba271c5263d2d 100644 (file)
@@ -1,27 +1,42 @@
+SUBDIRS = libeggtrayicon
+
 plugindir = $(pkglibdir)/plugins
 
 plugin_LTLIBRARIES = trayicon.la
 
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lsylpheed-claws
+else
+cygwin_export_lib = 
+endif 
+
 trayicon_la_SOURCES = \
-       trayicon.c \
-       eggtrayicon.c eggtrayicon.h
+       trayicon.c
 
 trayicon_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS)
+       -avoid-version -module -no-undefined
+
+trayicon_la_LIBADD = libeggtrayicon/libeggtrayicon.la \
+       $(cygwin_export_lib) \
+       $(GTK_LIBS) \
+       -L/usr/X11R6/lib -lX11
 
 INCLUDES = \
-       -I../../ \
-       -I../../common \
-       -I../../gtk
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       -I$(srcdir)/libeggtrayicon
 
-CPPFLAGS = \
+AM_CPPFLAGS = \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(ASPELL_CFLAGS)
+       $(ASPELL_CFLAGS) \
+       $(OPENSSL_CFLAGS) 
 
 EXTRA_DIST = \
        README \
        newmail.xpm \
+       newmarkedmail.xpm \
        nomail.xpm \
-       unreadmail.xpm
+       unreadmail.xpm \
+       unreadmarkedmail.xpm