metainfo: add tnef_parse plugin
[claws.git] / src / plugins / tnef_parse / Makefile.am
index a4d13364f0d4306f9469a953c21470f12aaed2e9..f1897fcc44873e11bca4630b8449afc77f0f35f4 100644 (file)
@@ -1,9 +1,16 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/tnef_parse" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-tnef_parse.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -43,14 +50,15 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_TNEF_PARSE_PLUGIN
 plugin_LTLIBRARIES = tnef_parse.la
+endif
 
 tnef_parse_la_SOURCES = \
          tnef_parse.c \
          tnef_dump.c \
          tnef_dump.h \
-        ytnef.c \
-        gettext.h
+        ytnef.c
 
 tnef_parse_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
@@ -71,15 +79,13 @@ noinst_HEADERS = \
        tnef-types.h \
        ytnef.h
 
-INCLUDES = \
+IFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+tnef_parse_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GTK_CFLAGS)