add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / tnef_parse / Makefile.am
index 699bc7bfdf91759d97e35a9851dcd7501321aa0e..37845077047c2daa00d927d63a2b36872cc37585 100644 (file)
@@ -1,9 +1,13 @@
+# Makefile.am for "src/plugins/tnef_parse" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 EXTRA_DIST = claws.def plugin.def version.rc
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -43,7 +47,9 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_TNEF_PARSE_PLUGIN
 plugin_LTLIBRARIES = tnef_parse.la
+endif
 
 tnef_parse_la_SOURCES = \
          tnef_parse.c \
@@ -70,15 +76,13 @@ noinst_HEADERS = \
        tnef-types.h \
        ytnef.h
 
-INCLUDES = \
+IFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+tnef_parse_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GTK_CFLAGS)