add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / spamassassin / Makefile.am
index 6f87d6f8f17137b60fb6fbb0945bfbb22b60007d..748b67910e596caa9be91393f678cbafcb0998de 100644 (file)
@@ -1,35 +1,37 @@
+# Makefile.am for "src/plugins/spamassassin" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
-plugin_DATA=spamassassin_gtk.deps
 
-plugin_LTLIBRARIES = spamassassin.la spamassassin_gtk.la
+if BUILD_SPAMASSASSIN_PLUGIN
+plugin_LTLIBRARIES = spamassassin.la
+endif
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
+       spamassassin_gtk.c spamassassin.h \
        libspamc.c libspamc.h \
        utils.c utils.h
 
 spamassassin_la_LDFLAGS = \
-       -avoid-version -module \
+       -avoid-version -module
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
+spamassassin_la_LIBADD = $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-spamassassin_gtk_la_SOURCES = \
-       spamassassin_gtk.c spamassassin.h
-
-spamassassin_gtk_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS) \
-       $(OPENSSL_LIBS)
-
-INCLUDES = \
-       -I../.. \
-       -I../../common \
-       -I../../gtk
-
-AM_CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+spamassassin_la_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(GTK_CFLAGS)
 
-EXTRA_DIST = \
-       README spamassassin_gtk.deps
+EXTRA_DIST = README