fix automake errors
[claws.git] / src / plugins / spamassassin / Makefile.am
index 92a9e25f0562cffa36d375f83949219f16ed793c..6d3996b206cfff056c834f58a8b28130be8c79f1 100644 (file)
@@ -1,34 +1,41 @@
+# Makefile.am for "src/plugins/spamassassin" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-spamassasin.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = spamassassin.la spamassassin_gtk.la
+if BUILD_SPAMASSASSIN_PLUGIN
+plugin_LTLIBRARIES = spamassassin.la
+endif
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
+       spamassassin_gtk.c spamassassin.h \
        libspamc.c libspamc.h \
        utils.c utils.h
 
 spamassassin_la_LDFLAGS = \
-       -avoid-version -module \
+       -avoid-version -module
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
+spamassassin_la_LIBADD = $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-spamassassin_gtk_la_SOURCES = \
-       spamassassin_gtk.c spamassassin.h
-
-spamassassin_gtk_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS) \
-       $(OPENSSL_LIBS)
-
-INCLUDES = \
-       -I../.. \
-       -I../../common \
-       -I../../gtk
-
-AM_CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+spamassassin_la_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(GTK_CFLAGS)
 
-EXTRA_DIST = \
-       README
+EXTRA_DIST = README $(appdata_files)