2008-09-12 [colin] 3.5.0cvs103
[claws.git] / src / plugins / spamassassin / Makefile.am
index 6f87d6f8f17137b60fb6fbb0945bfbb22b60007d..59a0aece76a16d69b59322959c373d327d72a0f0 100644 (file)
@@ -1,35 +1,37 @@
 plugindir = $(pkglibdir)/plugins
-plugin_DATA=spamassassin_gtk.deps
 
-plugin_LTLIBRARIES = spamassassin.la spamassassin_gtk.la
+plugin_LTLIBRARIES = spamassassin.la
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
+       spamassassin_gtk.c spamassassin.h \
        libspamc.c libspamc.h \
        utils.c utils.h
 
 spamassassin_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS)
-
-spamassassin_gtk_la_SOURCES = \
-       spamassassin_gtk.c spamassassin.h
-
-spamassassin_gtk_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS) \
-       $(OPENSSL_LIBS)
+       -avoid-version -module
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
+spamassassin_la_LIBADD = $(cygwin_export_lib) \
+       $(GTK_LIBS)     \
+       $(OPENSSL_LIBS) \
+       $(MAEMO_LIBS)
 
 INCLUDES = \
-       -I../.. \
-       -I../../common \
-       -I../../gtk
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(MAEMO_CFLAGS)
 
 EXTRA_DIST = \
-       README spamassassin_gtk.deps
+       README