RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / spamassassin / Makefile.am
index d3999534fde1efbb0e887fb9260fd3878d2e64bf..40525a943ffe3c1c1b3b8bf3c4131d9f5dc7b47e 100644 (file)
@@ -1,32 +1,38 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = spamassassin.la spamassassin_gtk.la
+if BUILD_SPAMASSASSIN_PLUGIN
+plugin_LTLIBRARIES = spamassassin.la
+endif
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
+       spamassassin_gtk.c spamassassin.h \
        libspamc.c libspamc.h \
        utils.c utils.h
 
 spamassassin_la_LDFLAGS = \
-       -avoid-version -module \
+       -avoid-version -module
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
+spamassassin_la_LIBADD = $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-spamassassin_gtk_la_SOURCES = \
-       spamassassin_gtk.c spamassassin.h
-
-spamassassin_gtk_la_LDFLAGS = \
-       -avoid-version -module \
-       $(GTK_LIBS)
-
-INCLUDES = \
-       -I../.. \
-       -I../../common \
-       -I../../gtk
-
-CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+spamassassin_la_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)
 
-EXTRA_DIST = \
-       README
+EXTRA_DIST = README