RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / spamassassin / Makefile.am
index 59a0aece76a16d69b59322959c373d327d72a0f0..40525a943ffe3c1c1b3b8bf3c4131d9f5dc7b47e 100644 (file)
@@ -1,6 +1,13 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_SPAMASSASSIN_PLUGIN
 plugin_LTLIBRARIES = spamassassin.la
+endif
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
@@ -17,21 +24,15 @@ else
 cygwin_export_lib =
 endif
 spamassassin_la_LIBADD = $(cygwin_export_lib) \
-       $(GTK_LIBS)     \
-       $(OPENSSL_LIBS) \
-       $(MAEMO_LIBS)
+       $(GTK_LIBS)
 
-INCLUDES = \
+spamassassin_la_CPPFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
        $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(MAEMO_CFLAGS)
+       $(GTK_CFLAGS)
 
-EXTRA_DIST = \
-       README
+EXTRA_DIST = README