RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / spamassassin / Makefile.am
index 51e7c901e20d29dd34df5463e02c088df6d102ff..40525a943ffe3c1c1b3b8bf3c4131d9f5dc7b47e 100644 (file)
@@ -1,6 +1,13 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_SPAMASSASSIN_PLUGIN
 plugin_LTLIBRARIES = spamassassin.la
+endif
 
 spamassassin_la_SOURCES = \
        spamassassin.c spamassassin.h \
@@ -9,19 +16,23 @@ spamassassin_la_SOURCES = \
        utils.c utils.h
 
 spamassassin_la_LDFLAGS = \
-       -avoid-version -module \
+       -avoid-version -module
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
+spamassassin_la_LIBADD = $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-INCLUDES = \
+spamassassin_la_CPPFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(GTK_CFLAGS)
 
-EXTRA_DIST = \
-       README
+EXTRA_DIST = README