metainfo: add spam_report plugin
[claws.git] / src / plugins / spam_report / Makefile.am
index f0d57a3f1d3f10718ad8417d963d7cd4da7dceea..c2ec35eb9abd072d68cc81146be89f8cf056b4e2 100644 (file)
@@ -1,9 +1,22 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/spam_report" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-spam_report.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -53,23 +66,18 @@ spamreport_la_SOURCES = \
         spam_report_prefs.h
 
 spamreport_la_LDFLAGS = \
+       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
        $(GTK_LIBS)
 
-spamreport_la_LIBADD = \
+spamreport_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(CURL_LIBS) \
        $(GTK_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+spamreport_la_DEPENDENCIES = $(plugin_deps)
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+spamreport_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(CURL_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GTK_CFLAGS)