metainfo: add spam_report plugin
[claws.git] / src / plugins / spam_report / Makefile.am
index 9d6a72095e890eb7e8b6c1b53b4d30e06d3be765..c2ec35eb9abd072d68cc81146be89f8cf056b4e2 100644 (file)
@@ -1,31 +1,83 @@
+# Makefile.am for "src/plugins/spam_report" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-spam_report.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
+if OS_WIN32
+
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.lo : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+plugin_res = version.lo
+plugin_res_ldflag = -Wl,.libs/version.o
+
+export_symbols = -export-symbols $(srcdir)/plugin.def
+
+plugin_deps = libclaws.a $(plugin_res) plugin.def
+
+libclaws.a: claws.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+plugin_ldadd = -L. -lclaws
+
+else
+plugin_res =
+plugin_res_ldflag =
+export_symbols =
+plugin_deps =
+plugin_ldadd =
+endif
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+else
+no_undefined =
+endif
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib = 
+endif
+
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_SPAM_REPORT_PLUGIN
 plugin_LTLIBRARIES = spamreport.la
+endif
 
 spamreport_la_SOURCES = \
          spam_report.c \
         spam_report_prefs.c \
-        spam_report_prefs.h \
-        gettext.h
+        spam_report_prefs.h
 
 spamreport_la_LDFLAGS = \
+       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
        $(GTK_LIBS)
 
-spamreport_la_LIBADD = \
+spamreport_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(CURL_LIBS) \
        $(GTK_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+spamreport_la_DEPENDENCIES = $(plugin_deps)
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+spamreport_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(CURL_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GTK_CFLAGS)