2008-12-15 [colin] 3.6.1cvs78
[claws.git] / src / plugins / smime / Makefile.am
index 347d1647e3bd13cc96820b41c90d45ad5f49075b..cc7f5733906816bd0ccac369e82bd9c6e30532c1 100644 (file)
@@ -1,18 +1,73 @@
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def smime.deps
+
+
+if OS_WIN32
+
+LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.lo : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+plugin_res = version.lo
+plugin_res_ldflag = -Wl,.libs/version.o
+
+export_symbols = -export-symbols $(srcdir)/plugin.def
+
+plugin_deps = libclaws.a libmypgpcore.a $(plugin_res) plugin.def
+
+libclaws.a: claws.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+libmypgpcore.a: mypgpcore.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+plugin_ldadd = -L . -lclaws  -lmypgpcore
+
+else
+plugin_res =
+plugin_res_ldflag =
+export_symbols =
+plugin_deps =
+plugin_ldadd =
+endif
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+else
+no_undefined =
+endif
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+pgpcore_lib = ../pgpcore/pgpcore.la
+else
+cygwin_export_lib = 
+pgpcore_lib = 
+endif
+
 plugindir = $(pkglibdir)/plugins
+plugin_DATA=smime.deps
 
 plugin_LTLIBRARIES = smime.la
-plugin_DATA = smime.deps
 
 smime_la_SOURCES = \
        plugin.c \
        smime.c
 
-smime_la_LDFLAGS = \
-       -avoid-version -module
+pluginincludedir = $(pkgincludedir)/plugins/smime
+plugininclude_HEADERS = \
+       smime.h 
 
-smime_la_LIBADD = \
-       $(GTK_LIBS) \
-       $(GPGME_LIBS)
+smime_la_LDFLAGS = \
+       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
+       -avoid-version -module 
+smime_la_DEPENDENCIES = $(plugin_deps)
+smime_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
+        $(GTK_LIBS)  \
+       $(GPGME_LIBS) \
+       $(CONIC_LIBS)
 
 INCLUDES = \
        -I$(top_srcdir)/src \
@@ -21,11 +76,12 @@ INCLUDES = \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
        -Wno-deprecated-declarations
 
-EXTRA_DIST = \
-       smime.h smime.deps
+clean-local:
+       rm -f libclaws.a