RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / smime / Makefile.am
index 347d1647e3bd13cc96820b41c90d45ad5f49075b..85b1f5807fb2798a62270933ebe19d780b161289 100644 (file)
@@ -1,31 +1,93 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def smime.deps
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
+if OS_WIN32
+
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.lo : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+plugin_res = version.lo
+plugin_res_ldflag = -Wl,.libs/version.o
+
+export_symbols = -export-symbols $(srcdir)/plugin.def
+
+plugin_deps = libclaws.a libmypgpcore.a $(plugin_res) plugin.def
+
+libclaws.a: claws.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+libmypgpcore.a: mypgpcore.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+plugin_ldadd = -L. -lclaws  -lmypgpcore
+
+else
+plugin_res =
+plugin_res_ldflag =
+export_symbols =
+plugin_deps =
+plugin_ldadd =
+endif
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+else
+no_undefined =
+endif
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+pgpcore_lib = ../pgpcore/pgpcore.la
+else
+cygwin_export_lib = 
+pgpcore_lib = 
+endif
+
 plugindir = $(pkglibdir)/plugins
+plugin_DATA=smime.deps
 
+if BUILD_SMIME_PLUGIN
 plugin_LTLIBRARIES = smime.la
-plugin_DATA = smime.deps
+endif
 
 smime_la_SOURCES = \
        plugin.c \
        smime.c
 
-smime_la_LDFLAGS = \
-       -avoid-version -module
+pluginincludedir = $(pkgincludedir)/plugins/smime
+plugininclude_HEADERS = \
+       smime.h 
 
-smime_la_LIBADD = \
-       $(GTK_LIBS) \
-       $(GPGME_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+smime_la_LDFLAGS = \
+       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
+       -avoid-version -module 
+smime_la_DEPENDENCIES = $(plugin_deps)
+smime_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
+        $(GTK_LIBS)  \
+       $(GPGME_LIBS) \
+       $(ENCHANT_LIBS)
 
-AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
+smime_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations
 
-EXTRA_DIST = \
-       smime.h smime.deps
+clean-local:
+       rm -f libclaws.a