add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / smime / Makefile.am
index ccfb23f2d387db8c822839c7757ecaae54519aef..177b61a489354ab12e3c8a56fdafbe9f8c12b3a8 100644 (file)
@@ -1,10 +1,19 @@
+# Makefile.am for "src/plugins/smime" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def smime.deps
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -50,7 +59,9 @@ endif
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=smime.deps
 
+if BUILD_SMIME_PLUGIN
 plugin_LTLIBRARIES = smime.la
+endif
 
 smime_la_SOURCES = \
        plugin.c \
@@ -67,21 +78,13 @@ smime_la_DEPENDENCIES = $(plugin_deps)
 smime_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(GPGME_LIBS) \
-       $(CONIC_LIBS) \
        $(ENCHANT_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+smime_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations