add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / rssyl / Makefile.am
index 2ed76432fba2d4325328bef0c3e2e751c9145dae..64417c97dc9c52a1537726c65a174ed5cf325d01 100644 (file)
@@ -1,9 +1,21 @@
+# Makefile.am for "src/plugins/rssyl" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+SUBDIRS = libfeed
+
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -47,42 +59,40 @@ if BUILD_RSSYL_PLUGIN
 plugin_LTLIBRARIES = rssyl.la
 endif
 
-INCLUDES= \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
 rssyl_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
        $(GTK_LIBS)
 
-rssyl_la_DEPENDENCIES = $(plugin_deps)
+rssyl_la_DEPENDENCIES = $(plugin_deps) libfeed/libfeed.la
 
 rssyl_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
-       $(GTK_LIBS) $(LIBXML_LIBS) $(CURL_LIBS)
+       $(GTK_LIBS) $(CURL_LIBS) libfeed/libfeed.la
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+rssyl_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(LIBXML_CFLAGS) \
-       $(CURL_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" 
+       $(CURL_CFLAGS)
 
 rssyl_la_SOURCES = \
-       date.c date.h \
-       feed.c feed.h \
-       feedprops.c feedprops.h \
-       opml.c opml.h \
-       parsers.c parsers.h \
+       old_feeds.c old_feeds.h \
+       opml_export.c opml_export.h \
+       opml_import.c opml_import.h \
+       parse822.c parse822.h \
        plugin.c \
        rssyl.c rssyl.h \
-       rssyl_cb_gtk.c rssyl_cb_gtk.h \
+       rssyl_add_item.c rssyl_add_item.h \
        rssyl_cb_menu.c rssyl_cb_menu.h \
+       rssyl_deleted.c rssyl_deleted.h \
+       rssyl_feed.c rssyl_feed.h \
+       rssyl_feed_props.c rssyl_feed_props.h \
        rssyl_gtk.c rssyl_gtk.h \
+       rssyl_parse_feed.c rssyl_parse_feed.h \
        rssyl_prefs.c rssyl_prefs.h \
-       strreplace.c strreplace.h
-
+       rssyl_update_comments.c rssyl_update_comments.h \
+       rssyl_update_feed.c rssyl_update_feed.h \
+       rssyl_update_format.c rssyl_update_format.h \
+       rssyl_subscribe.c rssyl_subscribe.h \
+       rssyl_subscribe_gtk.c rssyl_subscribe_gtk.h \
+       strutils.c strutils.h