metainfo: add rssyl plugin
[claws.git] / src / plugins / rssyl / Makefile.am
index 2ed76432fba2d4325328bef0c3e2e751c9145dae..1c4a44ea1f96dc30a8b6aa04a462caf2312f7030 100644 (file)
@@ -1,9 +1,22 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/rssyl" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-rssyl.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -47,12 +60,6 @@ if BUILD_RSSYL_PLUGIN
 plugin_LTLIBRARIES = rssyl.la
 endif
 
-INCLUDES= \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
 rssyl_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
@@ -63,14 +70,12 @@ rssyl_la_DEPENDENCIES = $(plugin_deps)
 rssyl_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS) $(LIBXML_LIBS) $(CURL_LIBS)
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+rssyl_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(LIBXML_CFLAGS) \
-       $(CURL_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" 
+       $(CURL_CFLAGS)
 
 rssyl_la_SOURCES = \
        date.c date.h \