Python plugin: Improve error reporting during plugin init
[claws.git] / src / plugins / python / Makefile.am
index 605e6b6c2812232c9bf8d789485e0e660b483bc7..bee41ec581878ef4302ad88f9c7c9ce9d7bfa18a 100644 (file)
@@ -1,8 +1,12 @@
+SUBDIRS = examples
+
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = python_plugin.la
+if BUILD_PYTHON_PLUGIN
+plugin_LTLIBRARIES = python.la
+endif
 
-python_plugin_la_SOURCES = \
+python_la_SOURCES = \
        clawsmailmodule.c \
        clawsmailmodule.h \
        composewindowtype.c \
@@ -17,10 +21,9 @@ python_plugin_la_SOURCES = \
        python-hooks.c \
        python-hooks.h \
        python-shell.c \
-       python-shell.h \
-       gettext.h
+       python-shell.h
 
-python_plugin_la_LDFLAGS = \
+python_la_LDFLAGS = \
        -avoid-version -module \
        $(GLIB_LIBS) \
        $(GTK_LIBS) \
@@ -30,16 +33,14 @@ python_plugin_la_LDFLAGS = \
 INCLUDES = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(PYTHON_CFLAGS) \
        $(PYGTK_CFLAGS) \
        -DPYTHON_SHARED_LIB="\"$(PYTHON_SHARED_LIB)\"" \
        -DENABLE_PYTHON \
-       -fno-strict-aliasing \
-       -DLOCALEDIR=\""$(localedir)"\"
+       -fno-strict-aliasing