Python plugin: Improve error reporting during plugin init
[claws.git] / src / plugins / python / Makefile.am
index 5d2f82e9e4c2b4e09564f2bd9fa57c9c0485c996..bee41ec581878ef4302ad88f9c7c9ce9d7bfa18a 100644 (file)
@@ -1,10 +1,12 @@
+SUBDIRS = examples
+
 plugindir = $(pkglibdir)/plugins
 
 if BUILD_PYTHON_PLUGIN
-plugin_LTLIBRARIES = python_plugin.la
+plugin_LTLIBRARIES = python.la
 endif
 
-python_plugin_la_SOURCES = \
+python_la_SOURCES = \
        clawsmailmodule.c \
        clawsmailmodule.h \
        composewindowtype.c \
@@ -21,7 +23,7 @@ python_plugin_la_SOURCES = \
        python-shell.c \
        python-shell.h
 
-python_plugin_la_LDFLAGS = \
+python_la_LDFLAGS = \
        -avoid-version -module \
        $(GLIB_LIBS) \
        $(GTK_LIBS) \
@@ -35,13 +37,10 @@ INCLUDES = \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(PYTHON_CFLAGS) \
        $(PYGTK_CFLAGS) \
        -DPYTHON_SHARED_LIB="\"$(PYTHON_SHARED_LIB)\"" \
        -DENABLE_PYTHON \
-       -fno-strict-aliasing \
-       -DLOCALEDIR=\""$(localedir)"\"
+       -fno-strict-aliasing