fix CID 1596595: Resource leaks, and CID 1596594: (CHECKED_RETURN)
[claws.git] / src / plugins / pgpmime / Makefile.am
index 3145d153575f6f8705434546eb37d360432a0799..add068e15353adbe42d6c7bd24308143cfbc20ed 100644 (file)
@@ -1,82 +1,50 @@
-EXTRA_DIST = version.rc plugin.def sylpheed.def mypgpcore.def pgpmime.deps
+# Copyright 1999-2022 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
-if OS_WIN32
+include $(srcdir)/../win_plugin.mk
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
-     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+EXTRA_DIST = pgpmime.deps
 
-%.lo : %.rc
-       $(LTRCCOMPILE) -i $< -o $@
-
-plugin_res = version.lo
-plugin_res_ldflag = -Wl,.libs/version.o
-
-export_symbols = -export-symbols $(srcdir)/plugin.def
-
-plugin_deps = libsylpheed.a libmypgpcore.a $(plugin_res) plugin.def
-
-libsylpheed.a: sylpheed.def
-       $(DLLTOOL) --output-lib $@ --def $<
-
-libmypgpcore.a: mypgpcore.def
-       $(DLLTOOL) --output-lib $@ --def $<
-
-plugin_ldadd = -L . -lsylpheed -lmypgpcore
-
-else
-plugin_res =
-plugin_res_ldflag =
-export_symbols =
-plugin_deps =
-plugin_ldadd =
-endif
+IFLAGS = \
+       -I$(top_builddir)/src \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
-if PLATFORM_WIN32
-no_undefined = -no-undefined
-else
-no_undefined =
-endif
-
-if CYGWIN
-cygwin_export_lib = -L$(top_builddir)/src -lsylpheed-claws
-pgpcore_lib = ../pgpcore/pgpcore.la
-else
-pgpcore_lib = 
-endif
+include $(srcdir)/../win_pgpcore.mk
 
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=pgpmime.deps
 
+if BUILD_PGPMIME_PLUGIN
 plugin_LTLIBRARIES = pgpmime.la
-
-
-pgpmime_la_SOURCES = \
-       plugin.c \
-       pgpmime.c
-
-pluginincludedir = $(pkgincludedir)/plugins/pgpmime
-plugininclude_HEADERS = \
-       pgpmime.h 
+endif
 
 pgpmime_la_LDFLAGS = \
-       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
-       -avoid-version -module 
-pgpmime_la_DEPENDENCIES = $(plugin_deps)
-pgpmime_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
-        $(GTK_LIBS) \
-       $(GPGME_LIBS)
+       $(plugin_ldflags) \
+       -avoid-version -module -z noexecstack
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
+EXTRA_pgpmime_la_DEPENDENCIES = $(plugin_extra_deps)
 
-AM_CPPFLAGS = \
+pgpmime_la_LIBADD = $(plugin_libadd) \
+       $(GTK_LIBS) \
+       $(GPGME_LIBS) \
+       $(ENCHANT_LIBS)
+
+pgpmime_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations
 
-clean-local:
-       rm -f libsylpheed.a
+pgpmime_la_SOURCES = \
+       pgpmime.c \
+       pgpmime.h \
+       plugin.c
+
+.PHONY: test