metainfo: add pgpmime plugin
[claws.git] / src / plugins / pgpmime / Makefile.am
index 0cf726998ba99f09e3b992679133dea78847ec21..124c682a92bbcdf723243c8961937c498e7368a4 100644 (file)
@@ -1,9 +1,23 @@
-EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpmime.deps
+# Makefile.am for "src/plugins/pgpmime" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-pgpmime.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpmime.deps \
+                                                $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -48,8 +62,9 @@ endif
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=pgpmime.deps
 
+if BUILD_PGPMIME_PLUGIN
 plugin_LTLIBRARIES = pgpmime.la
-
+endif
 
 pgpmime_la_SOURCES = \
        plugin.c \
@@ -66,22 +81,13 @@ pgpmime_la_DEPENDENCIES = $(plugin_deps)
 pgpmime_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS) \
        $(GPGME_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
        $(ENCHANT_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpmime_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations