RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / pgpinline / Makefile.am
index 9636414909871537396aa6d35a8c16f8766c2927..cd49aef42fe3262c8f37227557a6e3d1eb322d36 100644 (file)
@@ -1,10 +1,20 @@
-EXTRA_DIST = version.rc plugin.def sylpheed.def mypgpcore.def pgpinline.deps
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -15,15 +25,15 @@ plugin_res_ldflag = -Wl,.libs/version.o
 
 export_symbols = -export-symbols $(srcdir)/plugin.def
 
-plugin_deps = libsylpheed.a libmypgpcore.a $(plugin_res) plugin.def
+plugin_deps = libclaws.a libmypgpcore.a $(plugin_res) plugin.def
 
-libsylpheed.a: sylpheed.def
+libclaws.a: claws.def
        $(DLLTOOL) --output-lib $@ --def $<
 
 libmypgpcore.a: mypgpcore.def
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lsylpheed  -lmypgpcore
+plugin_ldadd = -L. -lclaws  -lmypgpcore
 
 else
 plugin_res =
@@ -50,7 +60,9 @@ endif
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=pgpinline.deps
 
+if BUILD_PGPINLINE_PLUGIN
 plugin_LTLIBRARIES = pgpinline.la
+endif
 
 pgpinline_la_SOURCES = \
        plugin.c \
@@ -68,16 +80,12 @@ pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(GPGME_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpinline_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local:
-       rm -f libsylpheed.a
+       rm -f libclaws.a