add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / pgpinline / Makefile.am
index 9a9d8f6d64854425637b2756713c435f9c7e72c3..c639cf1e1182253cb36e0c76e29a9cacbc9d78b8 100644 (file)
@@ -1,10 +1,19 @@
+# Makefile.am for "src/plugins/pgpinline" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -23,7 +32,7 @@ libclaws.a: claws.def
 libmypgpcore.a: mypgpcore.def
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lclaws  -lmypgpcore
+plugin_ldadd = -L. -lclaws  -lmypgpcore
 
 else
 plugin_res =
@@ -50,7 +59,9 @@ endif
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=pgpinline.deps
 
+if BUILD_PGPINLINE_PLUGIN
 plugin_LTLIBRARIES = pgpinline.la
+endif
 
 pgpinline_la_SOURCES = \
        plugin.c \
@@ -66,21 +77,13 @@ pgpinline_la_LDFLAGS = \
 pgpinline_la_DEPENDENCIES = $(plugin_deps)
 pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
-       $(GPGME_LIBS) \
-       $(CONIC_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GPGME_LIBS)
 
-AM_CPPFLAGS = \
+pgpinline_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local: