2011-08-29 [colin] 3.7.10cvs6
[claws.git] / src / plugins / pgpinline / Makefile.am
index 2b9a75d2073a8ae6b28303fa458c4aadba2c7466..ba56c3fa2d070010d417fb51db9c3d85b1673fc5 100644 (file)
@@ -1,4 +1,4 @@
-EXTRA_DIST = version.rc plugin.def sylpheed.def mypgpcore.def pgpinline.deps
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
 
 
 if OS_WIN32
@@ -15,15 +15,15 @@ plugin_res_ldflag = -Wl,.libs/version.o
 
 export_symbols = -export-symbols $(srcdir)/plugin.def
 
-plugin_deps = libsylpheed.a libmypgpcore.a $(plugin_res) plugin.def
+plugin_deps = libclaws.a libmypgpcore.a $(plugin_res) plugin.def
 
-libsylpheed.a: sylpheed.def
+libclaws.a: claws.def
        $(DLLTOOL) --output-lib $@ --def $<
 
 libmypgpcore.a: mypgpcore.def
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lsylpheed  -lmypgpcore
+plugin_ldadd = -L. -lclaws  -lmypgpcore
 
 else
 plugin_res =
@@ -40,7 +40,7 @@ no_undefined =
 endif
 
 if CYGWIN
-cygwin_export_lib = -L$(top_builddir)/src -lsylpheed-claws
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
 pgpcore_lib = ../pgpcore/pgpcore.la
 else
 cygwin_export_lib = 
@@ -66,18 +66,22 @@ pgpinline_la_LDFLAGS = \
 pgpinline_la_DEPENDENCIES = $(plugin_deps)
 pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
-       $(GPGME_LIBS)
+       $(GPGME_LIBS) \
+       $(CONIC_LIBS)
 
 INCLUDES = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local:
-       rm -f libsylpheed.a
+       rm -f libclaws.a