metainfo: add pgpinline plugin
[claws.git] / src / plugins / pgpinline / Makefile.am
index 810c1a69f17ab301e18dd3061fb809616b44d555..acdac80a3bf5091be68d6d9cf9ca70095bc371b9 100644 (file)
@@ -1,10 +1,23 @@
-EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
+# Makefile.am for "src/plugins/pgpinline" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
 
+appdata_DATA = claws-mail-pgpinline.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps \
+                                                $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -70,13 +83,8 @@ pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(GPGME_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpinline_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \