fix automake errors
[claws.git] / src / plugins / pgpinline / Makefile.am
index 93efc6fd6cf2ace6a42e6b338a3277ccd53b7cda..a471d5367113227fa812d68173b3636adaef4329 100644 (file)
@@ -1,10 +1,23 @@
-EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
+# Makefile.am for "src/plugins/pgpinline" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
 
+appdata_files = claws-mail-pgpinline.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps \
+                                                $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -23,7 +36,7 @@ libclaws.a: claws.def
 libmypgpcore.a: mypgpcore.def
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lclaws  -lmypgpcore
+plugin_ldadd = -L. -lclaws  -lmypgpcore
 
 else
 plugin_res =
@@ -50,7 +63,9 @@ endif
 plugindir = $(pkglibdir)/plugins
 plugin_DATA=pgpinline.deps
 
+if BUILD_PGPINLINE_PLUGIN
 plugin_LTLIBRARIES = pgpinline.la
+endif
 
 pgpinline_la_SOURCES = \
        plugin.c \
@@ -68,12 +83,8 @@ pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(GPGME_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpinline_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \