fix automake errors
[claws.git] / src / plugins / pgpinline / Makefile.am
index 231a96b9265b2261bf58aa8eceffa9efd1386726..a471d5367113227fa812d68173b3636adaef4329 100644 (file)
@@ -1,10 +1,23 @@
-EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps
+# Makefile.am for "src/plugins/pgpinline" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
 
+appdata_files = claws-mail-pgpinline.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = version.rc plugin.def claws.def mypgpcore.def pgpinline.deps \
+                                                $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -68,21 +81,13 @@ pgpinline_la_LDFLAGS = \
 pgpinline_la_DEPENDENCIES = $(plugin_deps)
 pgpinline_la_LIBADD = $(plugin_ldadd) $(pgpcore_lib) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
-       $(GPGME_LIBS) \
-       $(CONIC_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GPGME_LIBS)
 
-AM_CPPFLAGS = \
+pgpinline_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local: