2005-07-19 [paul] 1.9.12cvs82
[claws.git] / src / plugins / pgpcore / sgpgme.c
index c4adca3..990f377 100644 (file)
@@ -29,6 +29,7 @@
 #include <glib.h>
 #include <glib/gi18n.h>
 #include <stdio.h>
+#include <errno.h>
 
 #include "sgpgme.h"
 #include "privacy.h"
@@ -366,12 +367,13 @@ void sgpgme_init()
                if (prefs_gpg_get_config()->gpg_warning) {
                        AlertValue val;
 
-                       val = alertpanel_message_with_disable
+                       val = alertpanel_full
                                (_("Warning"),
                                 _("GnuPG is not installed properly, or needs "
-                                  "to be upgraded.\n"
-                                  "OpenPGP support disabled."), 
-                               NULL, NULL, NULL, ALERT_WARNING);
+                                "to be upgraded.\n"
+                                "OpenPGP support disabled."),
+                                GTK_STOCK_CLOSE, NULL, NULL, TRUE, NULL,
+                                ALERT_WARNING, G_ALERTDEFAULT);
                        if (val & G_ALERTDISABLE)
                                prefs_gpg_get_config()->gpg_warning = FALSE;
                }