2006-06-29 [colin] 2.3.1cvs40
[claws.git] / src / plugins / pgpcore / sgpgme.c
index 37b5bd0d72c104459190654c1067be8b99cf4702..0d1ed252b8468d5007b4621978d8a8d22992edc4 100644 (file)
@@ -527,7 +527,8 @@ void sgpgme_init()
                                        engineInfo->version ? engineInfo->version:"???",
                                        engineInfo->req_version ? engineInfo->req_version:"???",
                                        engineInfo->file_name ? engineInfo->file_name:"???");
-                               if (gpgme_engine_check_version(engineInfo->protocol) != 
+                               if (engineInfo->protocol == GPGME_PROTOCOL_OpenPGP
+                               &&  gpgme_engine_check_version(engineInfo->protocol) != 
                                        GPG_ERR_NO_ERROR) {
                                        if (engineInfo->file_name && !engineInfo->version) {
                                                alertpanel_error(_("Gpgme protocol '%s' is unusable: "