RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / pgpcore / Makefile.am
index 68a08e66ac6bbe18498acb91e5d41570ab76fd8f..db67806ecb67dcfa15fe26f06ab0cdb7ffd6775b 100644 (file)
@@ -1,9 +1,20 @@
-EXTRA_DIST = version.rc plugin.def sylpheed.def
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
+EXTRA_DIST = version.rc plugin.def claws.def
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -14,12 +25,12 @@ plugin_res_ldflag = -Wl,.libs/version.o
 
 export_symbols = -export-symbols $(srcdir)/plugin.def
 
-plugin_deps = libsylpheed.a $(plugin_res) plugin.def
+plugin_deps = libclaws.a $(plugin_res) plugin.def
 
-libsylpheed.a: sylpheed.def
+libclaws.a: claws.def
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lsylpheed
+plugin_ldadd = -L. -lclaws
 
 else
 plugin_res =
@@ -43,22 +54,28 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_PGPCORE_PLUGIN
 plugin_LTLIBRARIES = pgpcore.la
+endif
 
 pgpcore_la_SOURCES = \
+       autocompletion.c \
        passphrase.c \
        plugin.c \
        prefs_gpg.c \
        select-keys.c \
        sgpgme.c \
+       pgp_utils.c \
        pgp_viewer.c
 
 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
 plugininclude_HEADERS = \
+       autocompletion.h \
        passphrase.h \
        prefs_gpg.h \
        select-keys.h \
        sgpgme.h \
+       pgp_utils.h \
        pgp_viewer.h
 
 pgpcore_la_LDFLAGS = \
@@ -67,19 +84,17 @@ pgpcore_la_LDFLAGS = \
 pgpcore_la_DEPENDENCIES = $(plugin_deps)
 pgpcore_la_LIBADD = $(cygwin_export_lib) $(plugin_ldadd) \
         $(GTK_LIBS) \
-       $(GPGME_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GPGME_LIBS) \
+       $(ENCHANT_LIBS)
 
-AM_CPPFLAGS = \
+pgpcore_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local:
-       rm -f libsylpheed.a
+       rm -f libclaws.a