RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / pgpcore / Makefile.am
index 4d0a0a3f6511fe9b3663b9e2e972b28c0d3b9d6a..db67806ecb67dcfa15fe26f06ab0cdb7ffd6775b 100644 (file)
@@ -1,9 +1,20 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 EXTRA_DIST = version.rc plugin.def claws.def
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -48,19 +59,23 @@ plugin_LTLIBRARIES = pgpcore.la
 endif
 
 pgpcore_la_SOURCES = \
+       autocompletion.c \
        passphrase.c \
        plugin.c \
        prefs_gpg.c \
        select-keys.c \
        sgpgme.c \
+       pgp_utils.c \
        pgp_viewer.c
 
 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
 plugininclude_HEADERS = \
+       autocompletion.h \
        passphrase.h \
        prefs_gpg.h \
        select-keys.h \
        sgpgme.h \
+       pgp_utils.h \
        pgp_viewer.h
 
 pgpcore_la_LDFLAGS = \
@@ -72,13 +87,8 @@ pgpcore_la_LIBADD = $(cygwin_export_lib) $(plugin_ldadd) \
        $(GPGME_LIBS) \
        $(ENCHANT_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpcore_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \