2011-07-30 [mir] 3.7.9cvs38
[claws.git] / src / plugins / pgpcore / Makefile.am
index 24d0eb9b074e73725d3d433f48197c59786d9442..5876615a384522c8cb763c0ce47facf3e09fc49d 100644 (file)
@@ -1,6 +1,6 @@
-EXTRA_DIST = version.rc plugin.def sylpheed.def
+EXTRA_DIST = version.rc plugin.def claws.def
 
 
-if PLATFORM_WIN32
+if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
      `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
      `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
@@ -12,25 +12,34 @@ LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
 plugin_res = version.lo
 plugin_res_ldflag = -Wl,.libs/version.o
 
 plugin_res = version.lo
 plugin_res_ldflag = -Wl,.libs/version.o
 
-no_undefined = -no-undefined
 export_symbols = -export-symbols $(srcdir)/plugin.def
 
 export_symbols = -export-symbols $(srcdir)/plugin.def
 
-plugin_deps = libsylpheed.a $(plugin_res) plugin.def
+plugin_deps = libclaws.a $(plugin_res) plugin.def
 
 
-libsylpheed.a: sylpheed.def
+libclaws.a: claws.def
        $(DLLTOOL) --output-lib $@ --def $<
 
        $(DLLTOOL) --output-lib $@ --def $<
 
-plugin_ldadd = -L . -lsylpheed
+plugin_ldadd = -L . -lclaws
 
 else
 plugin_res =
 plugin_res_ldflag =
 
 else
 plugin_res =
 plugin_res_ldflag =
-no_undefined =
 export_symbols =
 plugin_deps =
 plugin_ldadd =
 endif
 
 export_symbols =
 plugin_deps =
 plugin_ldadd =
 endif
 
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+else
+no_undefined =
+endif
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib =
+endif
 
 plugindir = $(pkglibdir)/plugins
 
 
 plugindir = $(pkglibdir)/plugins
 
@@ -41,34 +50,43 @@ pgpcore_la_SOURCES = \
        plugin.c \
        prefs_gpg.c \
        select-keys.c \
        plugin.c \
        prefs_gpg.c \
        select-keys.c \
-       sgpgme.c
+       sgpgme.c \
+       pgp_viewer.c
 
 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
 plugininclude_HEADERS = \
        passphrase.h \
        prefs_gpg.h \
        select-keys.h \
 
 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
 plugininclude_HEADERS = \
        passphrase.h \
        prefs_gpg.h \
        select-keys.h \
-       sgpgme.h
+       sgpgme.h \
+       pgp_viewer.h
 
 pgpcore_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
 
 pgpcore_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
-       -avoid-version -module \
-        $(GTK_LIBS) \
-       $(GPGME_LIBS)
+       -avoid-version -module 
 pgpcore_la_DEPENDENCIES = $(plugin_deps)
 pgpcore_la_DEPENDENCIES = $(plugin_deps)
-pgpcore_la_LIBADD = $(plugin_ldadd)
+pgpcore_la_LIBADD = $(cygwin_export_lib) $(plugin_ldadd) \
+        $(GTK_LIBS) \
+       $(GPGME_LIBS) \
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS) \
+       $(ENCHANT_LIBS)
 
 INCLUDES = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
 
 INCLUDES = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        -I$(top_srcdir)/src/gtk
 
 AM_CPPFLAGS = \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
+       $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        -Wno-deprecated-declarations
 
 clean-local:
        -Wno-deprecated-declarations
 
 clean-local:
-       rm -f libsylpheed.a
+       rm -f libclaws.a