add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / pgpcore / Makefile.am
index 236584e31fb6f1d8366c15bbed93667c81f51964..50abc807c7c1b9e3555d37fcd1f18bb4d0cf15b2 100644 (file)
@@ -1,9 +1,19 @@
+# Makefile.am for "src/plugins/pgpcore" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 EXTRA_DIST = version.rc plugin.def claws.def
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -48,6 +58,7 @@ plugin_LTLIBRARIES = pgpcore.la
 endif
 
 pgpcore_la_SOURCES = \
+       autocompletion.c \
        passphrase.c \
        plugin.c \
        prefs_gpg.c \
@@ -58,6 +69,7 @@ pgpcore_la_SOURCES = \
 
 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
 plugininclude_HEADERS = \
+       autocompletion.h \
        passphrase.h \
        prefs_gpg.h \
        select-keys.h \
@@ -74,13 +86,8 @@ pgpcore_la_LIBADD = $(cygwin_export_lib) $(plugin_ldadd) \
        $(GPGME_LIBS) \
        $(ENCHANT_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+pgpcore_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \