fix automake errors
[claws.git] / src / plugins / perl / Makefile.am
index c99bb4edd3f4195fce99771891674ea5c2b3167a..7d927853551ab464abc6078a128849abcca03f5c 100644 (file)
@@ -1,25 +1,38 @@
+# Makefile.am for "src/plugins/perl" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-perl.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+
+SUBDIRS = tools
+
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = perl_plugin.la
+if BUILD_PERL_PLUGIN
+plugin_LTLIBRARIES = perl.la
+endif
 
-perl_plugin_la_SOURCES = \
+perl_la_SOURCES = \
        perl_plugin.c perl_plugin.h \
        perl_gtk.c perl_gtk.h
 
-perl_plugin_la_LDFLAGS = \
+perl_la_LDFLAGS = \
        -avoid-version -module
 
-perl_plugin_la_LIBADD = \
+perl_la_LIBADD = \
        $(PERL_LDFLAGS) \
        $(GTK_LIBS)
 
-AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
+perl_la_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(PERL_CFLAGS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
+EXTRA_DIST = cm_perl.pod $(appdata_files)
+