metainfo: add notification plugin
[claws.git] / src / plugins / notification / Makefile.am
index 347c361b1ca15d92630d06f84da426284c44c9fc..4521a817bc95eb093ca9c11aa9cee56356ea415d 100644 (file)
@@ -1,19 +1,34 @@
-#if BUILD_HOTKEYS
-#hotkey_lib = libcmnpgtkhotkey.la
-#hotkey_lib_path = $(top_builddir)/src/plugins/notification/gtkhotkey/libcmnpgtkhotkey.la
-#else
+# Makefile.am for "src/plugins/notification" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-notification.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+
+if BUILD_HOTKEYS
+hotkey_lib = libcmnpgtkhotkey.la
+hotkey_lib_path = $(top_builddir)/src/plugins/notification/gtkhotkey/libcmnpgtkhotkey.la
+else
 hotkey_lib =
 hotkey_lib_path =
-#endif
-
+endif
 
-EXTRA_DIST = claws.def plugin.def version.rc
+SUBDIRS=gtkhotkey
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
 CFLAGS += "-Wall"
 
+IFLAGS = \
+       -I$(top_srcdir)/src/plugins/notification/gtkhotkey \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -53,9 +68,11 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = notification_plugin.la
+if BUILD_NOTIFICATION_PLUGIN
+plugin_LTLIBRARIES = notification.la
+endif
 
-notification_plugin_la_SOURCES = \
+notification_la_SOURCES = \
        notification_plugin.c notification_plugin.h \
        notification_core.c notification_core.h \
        notification_popup.c notification_popup.h \
@@ -70,33 +87,25 @@ notification_plugin_la_SOURCES = \
        notification_pixbuf.c notification_pixbuf.h \
        raw_claws_mail_logo_64x64.h
 
-notification_plugin_la_LDFLAGS = \
+notification_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module
 
-notification_plugin_la_DEPENDENCIES = $(plugin_deps) \
+notification_la_DEPENDENCIES = $(plugin_deps) \
        $(hotkey_lib_path)
 
-INCLUDES = \
-       -I$(top_srcdir)/src/plugins/notification/gtkhotkey \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-
-notification_plugin_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
+notification_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(libnotify_LIBS) \
        $(libindicate_LIBS) \
        $(libcanberra_gtk_LIBS) \
        $(hotkey_lib_path)
 
-notification_plugin_la_CPPFLAGS = \
+notification_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(NOTIFY_CFLAGS) \
-       $(CLAWS_MAIL_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" \
        $(libnotify_CFLAGS) \
        $(libindicate_CFLAGS) \
        $(libcanberra_gtk_CFLAGS)