fix `make dist`
[claws.git] / src / plugins / notification / Makefile.am
index 531db9c1e44a76d780077a2199d8481078f2c0a7..39fa2c04c8e799604da6ba56f805f830ce4cc7fa 100644 (file)
@@ -1,19 +1,31 @@
-#if BUILD_HOTKEYS
-#hotkey_lib = libcmnpgtkhotkey.la
-#hotkey_lib_path = $(top_builddir)/src/plugins/notification/gtkhotkey/libcmnpgtkhotkey.la
-#else
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
+if BUILD_HOTKEYS
+hotkey_lib = libcmnpgtkhotkey.la
+hotkey_lib_path = $(top_builddir)/src/plugins/notification/gtkhotkey/libcmnpgtkhotkey.la
+else
 hotkey_lib =
 hotkey_lib_path =
-#endif
-
+endif
 
+SUBDIRS=gtkhotkey
 EXTRA_DIST = claws.def plugin.def version.rc
 CFLAGS += "-Wall"
 
+IFLAGS = \
+       -I$(top_srcdir)/src/plugins/notification/gtkhotkey \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -53,10 +65,11 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
-plugin_LTLIBRARIES = notification_plugin.la
+if BUILD_NOTIFICATION_PLUGIN
+plugin_LTLIBRARIES = notification.la
+endif
 
-notification_plugin_la_SOURCES = \
-       gettext.h \
+notification_la_SOURCES = \
        notification_plugin.c notification_plugin.h \
        notification_core.c notification_core.h \
        notification_popup.c notification_popup.h \
@@ -68,36 +81,27 @@ notification_plugin_la_SOURCES = \
        notification_hotkeys.c notification_hotkeys.h \
        notification_prefs.c notification_prefs.h \
        notification_foldercheck.c notification_foldercheck.h \
-       notification_pixbuf.c notification_pixbuf.h \
-       raw_claws_mail_logo_64x64.h
+       notification_pixbuf.c notification_pixbuf.h
 
-notification_plugin_la_LDFLAGS = \
+notification_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module
 
-notification_plugin_la_DEPENDENCIES = $(plugin_deps) \
+notification_la_DEPENDENCIES = $(plugin_deps) \
        $(hotkey_lib_path)
 
-INCLUDES = \
-       -I$(top_srcdir)/src/plugins/notification/gtkhotkey \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-
-notification_plugin_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
+notification_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
         $(GTK_LIBS)  \
        $(libnotify_LIBS) \
        $(libindicate_LIBS) \
        $(libcanberra_gtk_LIBS) \
        $(hotkey_lib_path)
 
-notification_plugin_la_CPPFLAGS = \
+notification_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(NOTIFY_CFLAGS) \
-       $(CLAWS_MAIL_CFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" \
        $(libnotify_CFLAGS) \
        $(libindicate_CFLAGS) \
        $(libcanberra_gtk_CFLAGS)