metainfo: add newmail plugin
[claws.git] / src / plugins / newmail / Makefile.am
index af4ddbdc671d3bc95a9c1e1eca952b1e38af3779..36b183d978067d2ab98237078b105e5684c4175f 100644 (file)
@@ -1,6 +1,17 @@
+# Makefile.am for "src/plugins/newmail" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-newmail.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = $(appdata_files)
+
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_NEWMAIL_PLUGIN
 plugin_LTLIBRARIES = newmail.la
+endif
 
 newmail_la_SOURCES = \
        newmail.c
@@ -8,13 +19,10 @@ newmail_la_SOURCES = \
 newmail_la_LDFLAGS = \
        -avoid-version -module
 
-AM_CPPFLAGS = \
-        $(CLAWS_MAIL_CFLAGS) \
-       $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS)
-
-INCLUDES = \
+newmail_la_CPPFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       -I$(top_srcdir)/src/gtk \
+        $(GLIB_CFLAGS) \
+       $(GTK_CFLAGS)