add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / mailmbox / Makefile.am
index eadfae558982963d39006df4a698e80efeef999c..46caaece06506e66bbd27d34759b3785fb2cbe09 100644 (file)
@@ -1,3 +1,56 @@
+# Makefile.am for "src/plugins/mailmbox" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+EXTRA_DIST = claws.def plugin.def version.rc
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
+if OS_WIN32
+
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.lo : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+plugin_res = version.lo
+plugin_res_ldflag = -Wl,.libs/version.o
+
+export_symbols = -export-symbols $(srcdir)/plugin.def
+
+plugin_deps = libclaws.a $(plugin_res) plugin.def
+
+libclaws.a: claws.def
+       $(DLLTOOL) --output-lib $@ --def $<
+
+plugin_ldadd = -L. -lclaws
+
+else
+plugin_res =
+plugin_res_ldflag =
+export_symbols =
+plugin_deps =
+plugin_ldadd =
+endif
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+else
+no_undefined =
+endif
+
+if CYGWIN
+cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
+else
+cygwin_export_lib = 
+endif
+
 plugindir = $(pkglibdir)/plugins
 
 if BUILD_MAILMBOX_PLUGIN
@@ -30,17 +83,6 @@ mailmbox_la_LIBADD = \
        $(GTK_LIBS)
 
 mailmbox_la_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
-       $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS)
-
-AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk