update copyright year
[claws.git] / src / plugins / litehtml_viewer / Makefile.am
index 81ce76660a653f2aff86c3e0ea10204165c2131c..31c895e3aa59d17a18e39c71c52a0bc668f1840b 100644 (file)
@@ -1,27 +1,26 @@
-# Copyright 1999-2018 the Claws Mail team.
+# Copyright 1999-2022 the Claws Mail team.
 # This file is part of Claws Mail package, and distributed under the
 # terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
+include $(srcdir)/../win_plugin.mk
+
 SUBDIRS = litehtml
-EXTRA_DIST = claws.def plugin.def version.rc css.inc
 
 IFLAGS = \
-        -I$(top_srcdir)/src \
-        -I$(top_srcdir)/src/common \
-        -I$(top_builddir)/src \
-        -I$(top_srcdir)/src/gtk \
+       -I$(top_builddir)/src \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_srcdir)/src/gtk \
        -I$(top_srcdir)/src/plugins/litehtml_viewer/litehtml
 
-plugin_res =
-plugin_res_ldflag =
-export_symbols =
-plugin_deps =
-plugin_ldadd =
+plugin_cppflags =
+
+if OS_WIN32
 
-no_undefined =
+plugin_cppflags += -DLITEHTML_UTF8
 
-cygwin_export_lib =
+endif
 
 plugindir = $(pkglibdir)/plugins
 
@@ -29,46 +28,49 @@ if BUILD_LITEHTML_VIEWER_PLUGIN
 plugin_LTLIBRARIES = litehtml_viewer.la
 endif
 
-litehtml_viewer_la_DEPENDENCIES = $(plugin_deps)
-
-litehtml_viewer_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
-       $(top_builddir)/src/plugins/litehtml_viewer/litehtml/liblitehtml.la \
-        $(GTK_LIBS)
-
-litehtml_viewer_la_CXXFLAGS = -std=c++11
-litehtml_viewer_la_CFLAGS = -std=c99
+litehtml_viewer_la_LDFLAGS = \
+       $(plugin_ldflags) \
+       -avoid-version -module -z noexecstack
 
-litehtml_viewer_la_SOURCES = \
-       container_linux.cpp \
-       plugin.c \
-       lh_prefs.c \
-       lh_viewer.c \
-       lh_widget.cpp \
-       lh_widget_text.cpp \
-       container_linux.h \
-       lh_prefs.h \
-       lh_viewer.h \
-       lh_widget.h \
-       lh_widget_wrapped.h \
-       http.h \
-       http.cpp
+EXTRA_litehtml_viewer_la_DEPENDENCIES = $(plugin_extra_deps) \
+       litehtml/liblitehtml.la
 
-litehtml_viewer_la_LDFLAGS = \
-       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
-       -avoid-version -module \
+litehtml_viewer_la_LIBADD = $(plugin_libadd) \
        $(GTK_LIBS) \
        $(FONTCONFIG_LIBS) \
        $(CAIRO_LIBS) \
-       $(CURL_LIBS)
+       $(CURL_LIBS) \
+       $(LIBGUMBO_LIBS) \
+       litehtml/liblitehtml.la
 
 litehtml_viewer_la_CPPFLAGS = \
+       $(plugin_cppflags) \
        $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(FONTCONFIG_CFLAGS) \
        $(CAIRO_CFLAGS) \
-       $(CURL_FLAGS)
+       $(CURL_CFLAGS) \
+       $(LIBGUMBO_CFLAGS)
 
-.PHONY: test
+litehtml_viewer_la_CXXFLAGS = -std=c++11
+litehtml_viewer_la_CFLAGS = -std=c99
+
+litehtml_viewer_la_SOURCES = \
+       container_linux.cpp \
+       container_linux.h \
+       container_linux_images.cpp \
+       container_linux_images.h \
+       http.cpp \
+       http.h \
+       lh_prefs.c \
+       lh_prefs.h \
+       lh_viewer.c \
+       lh_viewer.h \
+       lh_widget.cpp \
+       lh_widget.h \
+       lh_widget_wrapped.h \
+       plugin.c
 
+.PHONY: test