Use Pango to render text in Litehtml plugin
[claws.git] / src / plugins / litehtml_viewer / Makefile.am
index 648960ce5d7aade76f6bd4bb0b6f1036bbdcc9bf..81ce76660a653f2aff86c3e0ea10204165c2131c 100644 (file)
@@ -25,9 +25,9 @@ cygwin_export_lib =
 
 plugindir = $(pkglibdir)/plugins
 
-#if BUILD_LITEHTML_VIEWER_PLUGIN
+if BUILD_LITEHTML_VIEWER_PLUGIN
 plugin_LTLIBRARIES = litehtml_viewer.la
-#endif
+endif
 
 litehtml_viewer_la_DEPENDENCIES = $(plugin_deps)
 
@@ -41,9 +41,12 @@ litehtml_viewer_la_CFLAGS = -std=c99
 litehtml_viewer_la_SOURCES = \
        container_linux.cpp \
        plugin.c \
+       lh_prefs.c \
        lh_viewer.c \
        lh_widget.cpp \
+       lh_widget_text.cpp \
        container_linux.h \
+       lh_prefs.h \
        lh_viewer.h \
        lh_widget.h \
        lh_widget_wrapped.h \
@@ -62,6 +65,7 @@ litehtml_viewer_la_CPPFLAGS = \
        $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        $(FONTCONFIG_CFLAGS) \
        $(CAIRO_CFLAGS) \
        $(CURL_FLAGS)