add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / gdata / Makefile.am
index 491fa951ee6fb1ac06a8b75b294fa62b4b4622fd..f43e8d21dfe387e0cd6132c25aef88f2afded6e4 100644 (file)
@@ -1,10 +1,14 @@
+# Makefile.am for "src/plugins/gdata" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
 
 if BUILD_GDATA_PLUGIN
-plugin_LTLIBRARIES = gdata_plugin.la
+plugin_LTLIBRARIES = gdata.la
 endif
 
-gdata_plugin_la_SOURCES = \
+gdata_la_SOURCES = \
        gdata_plugin.c \
        gdata_plugin.h \
        cm_gdata_contacts.c \
@@ -12,22 +16,16 @@ gdata_plugin_la_SOURCES = \
        cm_gdata_prefs.c \
        cm_gdata_prefs.h
 
-gdata_plugin_la_LDFLAGS = \
+gdata_la_LDFLAGS = \
        -avoid-version -module \
        $(GTK_LIBS) \
        $(GDATA_LIBS)
 
-
-INCLUDES = \
+gdata_la_CPPFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+       -I$(top_srcdir)/src/gtk \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS) \
-       $(GDATA_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GDATA_CFLAGS)